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TSDS PEIMS Fall Submission 1  

 
TSDS PEIMS – Submission Responsibilities & Requirements 
 
The Texas Student Data System (TSDS) is a statewide system for collecting and reporting 
education data for Texas publicly funded schools.   
 

2022-2023 PEIMS Fall Submission Timeline 
 

 
 
 
 
TSDS TWEDS – Texas Education Data Standards 
 
The data submitted through TSDS must be in XML format as defined in TEDS (Texas Education 
Data Standards).  The TEDS is located on the TSDS website. 
 
 http://www.texasstudentdatasystem.org/TSDS/TEDS/TEDS_Latest_Release/ 
 

 
 
 
According to TEDS the LEAs (Local Education Agencies) are responsible for: 
 

• Submitting current, complete, and accurate data for all XML files required for each 
submission 

• Validating and editing data according to the business rules and validations 
• Correcting all errors during the validation process 
• Delivering “fatal-free” corrected PEIMS data on or before any due dates set by the ESC 

or TEA. 
 
 
 
 

http://www.texasstudentdatasystem.org/TSDS/TEDS/TEDS_Latest_Release/
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TSDS TWEDS – eDM Dictionaries and Guides 
 
TEDS provides error dictionaries to assist in translating and troubleshooting errors in File 
Manager and Batch Manager as well as guides for deleting/reloading data.  There is also a guide 
that cross-references validation rules with the associated elements and interchanges. 
 

 
 
 
TSDS – PEIMS Access and User Roles 
 
The TSDS PEIMS application is only available to authorized ESC, district, and campus staff. A 
TEAL logon is required as well as access to the Texas Student Data System Portal. Different 
roles can be assigned to the user based on the access required. There are seven different roles 
in the PEIMS application, each with a different level of access. 
 

• ODS Data Loader (ESC/LEA) – This role allows the user to upload PEIMS Interchanges 
to TSDS. 

• PEIMS Campus Submitter (Campus) – This role allows the user to promote loaded 
data, validate (prepare) data, search all PEIMS data, and view PEIMS reports for a 
specific campus. 

• PEIMS Data Submitter (LEA) - This role allows the user to promote loaded data, 
validate (prepare) data, search all PEIMS data, and view PEIMS reports at the district 
level. 

• PEIMS Data Completer (LEA) – This role allows the user to promote loaded data, 
validate (prepare) data, complete (finalize) data, search all PEIMS data, and view reports 
at the district level.  

• PEIMS Data Approver (LEA Superintendent) – This role allows the Superintendent to 
approve the PEIMS data submission and apply for an extension if necessary. 

• PEIMS Data Accepter (ESC) - This role allows the user at the ESC to view and run 
reports, accept, or reject the PEIMS data submission. 
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Downloading Validation Tool  
 
TEA provides a Validation Tool to validate the format and naming conventions for the PEIMS 
interchanges.  The Validation Tool is in TEAL > Texas Student Data System Portal > Utilities 
for downloading. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

• Click Download Validation Tool to download the tool. 
• Click Download Validation Tool Instructions (pdf) to download a copy of the 

installation instructions. 
 
Note: If you have previously installed the Validation Tool, the Check for Updates option 
in it does not update to the most current version.  You must download and install the 
Validation Tool again. 
 
Validating PEIMS Interchanges – Validation Tool 
 
Once the Validation Tool has been downloaded and installed click on the validation tool icon to 
open the tool. 
 

 
 

• Select File > Validation Tool.  The Validation Tool opens in a separate window. 
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• Select the School Year 2022-2023. 
• Select the Collection. 
• Click the folder icon to browse for and select the PEIMS files (files must be unzipped). 
• Click Process Files.  The results of the validation are reported in the status field. 
• If you have files that Fail, you can click on the file name and click the Details button. 
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• The Detail Errors page appears, errors can be viewed on the screen by selecting Error 
Type (All, Fatal, Warning, or Special Warning). 

• Errors may also be printed by selecting Print All Errors or saved in Excel format by 
selecting Export All Errors. 

 

 
 

 
 

• Files can be manually loaded in TSDS by clicking on the Open TSDS button.  This will 
take you to the TEAL login screen. 

Note: Failed files will not load in TSDS. Files with errors will load, but errors will need to be 
corrected prior to finalizing the PEIMS Submission. 
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Uploading PEIMS files – TSDS PEIMS Data Upload 
 
The TSDS portal is the way to access any of the TSDS applications or utilities to which users 
have access. The tabs that appear on the portal depend upon the access that t been granted in 
TEAL. 
 
The eDM Data Loads tool allows users to load data from their local systems to TSDS. 
 

• Once logged into TEAL and select Texas Student Data System Portal. 
• On the Home screen select Manage Data Loads. 

 

 
 

• Under Interchange Menu, select Interchange Upload. 
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• Select the Interchange Collection from the drop-down menu. 
• Click the Browse button for File 1 and select the file from your computer. 
• Click the Browse button for File 2 and select the next file from your computer. 
• Continue until all require files have selected. 

 
Note: The files must be loaded in the following order: 
 

 InterchangeEducationOrganizationExtension 
 InterchangeStudentExtension 
 InterchangeStudentEnrollmentExtension 
 InterchangeStaffAssociationExtension 
 InterchangeStudentProgramExtension 
 InterchangeSSAOrganizationAssociationExtension 
 InterchangeFinanceExtension 

 
• Click Upload. The files are validated and uploaded to the File Manager. 

 
Note: Files can be zipped for easier upload. Select all files, right-click, and send to > 
Compressed (zipped) folder. Upload the one file. 
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• Once the files have been completely uploaded, the File Manager screen appears. 
 

• The files will be processed for errors. 
 

 Any failed files  will not batch. 

 Any files with errors will have a red  in the status column. To view errors click 
on the spyglass and scroll to the bottom of the screen and open the .TAB file. 
 

 
 Make all corrections necessary in the software, run the Validation Tool again, 

and resubmit the files. 
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• Once all the files have a green checkmark  in the status column, select all of the files 
and click Add to Batch.  The View Batch button appears. 

• Select the View Batch button.   
• From the next screen the user may add comments regarding the batch, remove files from 

the batch, delete files, or process the batch.  It is suggested that comments be added 
naming the file if the files are being uploaded manually. 
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• To remove files from the batch, select the appropriate files and click Remove from 

Batch. 
• The selected file is removed from the View Batch screen but remains in the File Manager. 

 

 
 

• Districts can delete data prior to processing the new batch. The Delete Utility has been 
integrated into the Batch Manager process. 

• To delete data, select Yes by Perform Delete Before Load. 
• From the Select Delete Option pulldown, select the data to be deleted. 

 
• To process the batch, select the appropriate files and click Process Batch. The Batch 

Manager screen appears: 
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• The Batch Manager screen appears with a list and status of all batches that have been 

processed. Batches can have a completed status with errors (red X) or no errors (green 
checkmark). 

 
• To view the files with errors, click the spyglass to open the batch and then click on the 

spyglass next to the file with errors; or 
• Click on Download All Error Files. 
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• To view the actual errors, click on the spyglass next to the ERROR.TAB file or the 
DUPLICATES.TAB file. 

 

• Click Cancel to return to previous screens. 
• Make corrections as needed in the software, create new interchanges, validate again, 

and resubmit the files. 
• Logout and Exit programs. 
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Promoting PEIMS files – TSDS PEIMS Promote Loaded Data 
 
The eDM Promote Loaded Data tool allows users to promote data that has been loaded and 
batched. 
 

• Log in to TEAL and select Texas Student Data System Portal. 
• On the Home screen select PEIMS>Promote Loaded Data.  

 

 
• The Data Promotion screen appears: 
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• Verify the correct submission is selected.  If not, select it from the pull-down menu and 
click GO. 

• From the Categories pull-down menu, select All Categories or the individual 
categories to be promoted. If individual categories are selected user may also select 
individual subcategories. 

• Enter a Data Promotion Name. 
• Click Next to continue or Reset to clear selections. 
• The Confirm Data Promotion screen appears: 

 

• Verify the Categories/Subcategories. 
• Click Submit, Cancel, or Back. 
• The Monitor Data Promotions screen appears: 
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• This screen shows the status of the data promotion, promotion error reports, and a 
confirmation message that the data was promoted. 

• To view promotion errors, click the View link under Error Report or click the LEA 
Promotion Errors button. 

• The LEA Data Promotion Errors screen appears: 
 

 
 

• This screen will list any errors by Category, Subcategory, Severity, along with the error 
message. Errors can be saved as a PDF or XLS file or can be printed by selecting the 
appropriate button. 
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Validating PEIMS files – TSDS PEIMS Promote Loaded Data > Validations 
 
This screen allows users to validate data that has promoted in TSDS. This is where the district 
will be able to view the Fatals, Warnings, and Special Warnings for the submission. 
 

• Log in to TEAL and select Texas Student Data System Portal. 
• On the Home screen select Promote Loaded Data. Select the Validations tab > Validate 

Submission Data. 
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• From the Categories pull-down menu, select All Categories or the individual 

categories that are to be validated. 
• Select the type of validation (Fatal, Warning, Special Warning). 
• Enter a Validation Name. 
• Click Next to continue the process or Reset to clear all options. 
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• The Confirm Data Validation screen appears: 

 
 

• Verify the Categories/Subcategories 
• Click Submit, Cancel, or Back. 
• The Monitor Data Validations screen appears: 
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• This screen shows the status of the data validations, validation error reports, and a 
confirmation message that the data has been submitted.  

• To view validation errors by job, click the LEA Validation Errors button or View under 
Error Report. 
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• This screen will list any errors by Category, Subcategory, Severity, along with the error 
message. 

• Errors can be sorted by the individual columns.  The errors can also be saved as a PDF 
or XLS file or can be printed by selecting the appropriate button. 
 

 
• To view errors by severity (Fatal, Special Warning, and Warning) select Validation Rules 

Count from the Validations pull-down. 
 

 
 

• Click on the “Show” link to view errors. 
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• Correct any fatals. Verify or correct any warnings or special warnings in the database, re-
create the files, upload, and promote and validate the data. 

 
Note: It is recommended that the district use the Delete Utility in TSDS > Manage Data 
Loads to clear the incorrect data from the ODS prior to uploading the new files. 
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TSDS – Search Data - TSDS PEIMS Promote Loaded Data>Access Data 
 
To access the data or student rosters, click on the Access Data tab and then select either 
Search Submission Data or Search Student Roster. 
 

 
 
Accessing PEIMS data using Search Submission Data 
 

 
 

• On the Data Search screen, select the search category from the Categories pull-down 
menu. The Subcategories field appears: 

 

 
 

• Select a Subcategory from the pull-down menu if required.  Once selected, additional 
fields appear based on the original category and subcategory selected. 



ESC Region 11  TSDS PEIMS Submission 1 2023 
_________________________________________________________________________________________________ 

_________________________________________________________________________________________________ 
Page 24 of 34                 Copyright © 2022 Education Service Center Region 11                              Created on 11/13/2014 
                                                                                                                                                                 Revised 10/12/2022 

 

 
• Click Search to view data matching entered criteria or click Reset to clear selected 

criteria. 
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• Show entries allows the user to select up to 500 entries to view at a time. 
• The Search Table field allows the user to filter the search by fields.  An example would 

be to search for only 8th grade (enter 08 in the field). 
• The search results can be Printed, saved/printed as a PDF or XLS. 
• The search results can be sorted by the individual columns by clicking on the column 

header. 
 
Accessing PEIMS data using Search Student Roster 
 
This search is used to help districts with their Leaver data.  The only students that can be 
searched on this screen are students that are grade levels 7-12 and are being reported as 
leavers. 
 

• Enter search criteria.  Any field with a red asterisk (*) is a required field. 
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TSDS – PEIMS View Reports 
 
Reports must be run and verified prior to and after completing and accepting the PEIMS data 
submission. These reports are the same as the reports in Edit+ and must be compared for 
accuracy of the submission. The TSDS PEIMS reports are separated into three categories:  
 

• Standard Reports – These reports are available at any time and reflect the current data 
loaded into PEIMS, whether the collection has been completed or not. 

• Special Reports – These reports are summary reports that help completers, approvers, 
and accepters review the data submission.  These reports also are available at any time 
and reflect the current data loaded into PEIMS, whether the collection has been 
completed or not. 

• Student Leaver Reports – These are the individual LEA reports that use data from 
across the state to help districts identify their leavers.  These reports are only in each 
submission after the submission has closed and TEA has calculated the leavers.  These 
reports only reflect finalized data. 

• UID Discrepancies – These reports are used to identify discrepancies between Unique 
ID data and PEIMS Demographic data. 

• Bundled Reports – These are reports that are generated together for ease of 
downloading. 

 
To access the reports: 
 

• Log in to TEAL and select Texas Student Data System Portal. 
• On the Home screen select View Reports.  Select the View Reports tab. 
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Under View Reports, select from the pull-down menu the report to run in the appropriate 
category. 
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• Click the circular arrow under Run.  The Report Parameters screen appears: 

 
• Reports can be run by district or campus by changing the Organization Level selection. 
• Select the appropriate parameters and click Run.  The View Reports page appears 

showing the status of the report.  The reports are associated to the individual user to 
prevent other users from overwriting the reports. 
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• Once the report is complete a hyperlink will appear allowing the report to be downloaded. 
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TSDS – PEIMS Prepare/Finalize Process (Sample Screenshots) 
 
Once data has been validated, the district will prepare and finalize the data which will include 
completing the process so that the ESC PEIMS coordinator can verify the submission. From this 
screen the district PEIMS Data Completer can lock categories once the categories are fatal free 
to prevent the data being overwritten. 
 

• Log in to TEAL and select Texas Student Data System Portal. 
• On the Home screen select Prepare/Finalize Data.   
• Verify that PEIMS is selected from the pull-down menu (if applicable). 

 

 
• Verify the correct collection has been selected. 
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• This screen shows records by Category and Subcategory.   
• In the Last Promoted On column is the time date stamp for the last time the data was 

promoted to PEIMS. 
• Promoted By lists the user name of the person that last promoted the data. 
• The number of records for the particular Category/Subcategory is listed in the Records 

column. 
• Click View in the Error Report field to view the Fatal, Special, and Warning errors for the 

particular Category/Subcategory. 
• The number of errors by Category/Subcategory are listed under the columns labeled: 

 
 F (Fatal) 
 SW (Special Warning) 
 W (Warning) 
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The current status (Promoted, Validated, etc.) of the Category/Subcategory is listed under the 
column Data Status. 

• The data on the screen can be saved/printed in PDF or XLS by clicking on the 
appropriate button.  

• A search can be done on the screen by using the Search field. 
• To verify or “lock” data, the category/subcategory must have a Data Status of Validated. 

Click the checkbox adjacent to the Category/Subcategory that needs to be verified and 
click Verify. 

• To “unlock” data, click the checkbox adjacent to the Category/Subcategory that needs to 
be unlocked and click Reset Verify. 
 
 

 
 

• The PEIMS Data Completer can click the Complete button to complete the file so the 
ESC can verify data.  All files must be fatal free in order to complete the files.  The 
Completion Process Status bar appears: 
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• Once validation process is complete, check the checkbox acknowledging the submission 

have been validated and reviewed for accuracy and authenticity and that all warnings and 
special warnings have been reviewed and confirmed. 

• Click the Confirm button and the data is now ready for the ESC to verify and accept or 
reject. 

• If rejected the district must correct the data and go through the whole process again. 
 

 
TSDS – Superintendent Approval Form (SAF) Process 
 
The Superintendent must approve all PEIMS submissions. This is accomplished through the 
Superintendent Approval Form (SAF) process. The Superintendent may also request an 
extension for one of the PEIMS submissions. All extensions must be approved by TEA. The 
district must have extenuating circumstances to receive an extension. 

 

ESC Region 11 grants permission to attendees of this session to reproduce and distribute designated resources and 
materials provided during the presentation. 
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